[xSidebar] SeaMonkey 2 + xSideBar 1.1 + Dictionary Switcher 0.9 = incompatible extension

Fernando Cassia fcassia at gmail.com
Sat Nov 21 06:34:47 PST 2009


2009/11/21 Philip Chee <philip.chee at gmail.com>

> 2009/11/21 Alfredo Fernández Díaz <mrwarper at yahoo.es>:
>
> > I'm just trying out SeaMonkey 2.0 so I went to get the latest xSidebar to
> be
> > able to install some of my favorite extensions. After installing SM 2 and
> > xSB 1.1, trying to install Dictionary 0.9mod always results in an
> 'Extension
> > not compatible with SeaMonkey 2.0' message after a nice progress bar and
> > oter good signs.
>
> Hmm. Did you modify your user agent setttings? If you go Help=>About
> SeaMonkey
> what is your Build Identifier?
>
> Phil
>

THis is perhaps related... and perhaps you could give a hand Phil...

I've been trying to install Googlebar (googlebar.mozdev.org) on SM 2.0
without success.
It spits out something about the extension "not providing secure updates".
It is not clear to me if it means that the extension is not installed over
https// or that the extension does not provide a mechanism to auto check for
updated versions.

I tried hacking the .xpi modding the <maxversion> parameter to 1.9.x or 2.0
and it doesn't make any difference.

I am at a complete loss as to what is going on.

I tried approaching several of the googlebar maintainers/contributors but
got nowhere.

FC
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mozdev.org/pipermail/xsidebar/attachments/20091121/dcf6166b/attachment.html>


More information about the Xsidebar mailing list