[Vimperator] [PATCH] make install to install in UUID path if present

Martin Stubenschrott stubenschrott at gmx.net
Sat Apr 28 09:05:22 PDT 2007


As discussed, I don't think it makes sense to support old UUIDs for
ages, just an error when vimperator at mozdev.net/chrome/vimperator.jar
does not exist, probably is the best to explain to the user, that he
initially needs to install vimperator first with the gui dialog to
register the extension.

to the version thing:

I think it would be the best to have ###VERSION### and ###DATE### seded
in the makfile, and then have

var g_vimperator_version  = "###VERSION### (created: ###DATE###)";
in vimperator.js;

Other files which need changes are:
* src/install.rdf
* dowloads/update.rdf (also changes to the updateLink URL)

With these changes, making new releases gets MUCH easier.

I already changed these files, so there just need to be a sed support in
the Makefile.


More information about the Vimperator mailing list