[Synckolab] restart address book sync from scratch

Miquel Mayor mikpublik at yahoo.es
Wed Jan 11 06:10:48 PST 2012


Hi everyone (not sure this mail is getting to many people or only to the developer)
First of all, excuse me if this is not the right place to ask my question. If so, please refer me where should I do so.

I work in a small office where I set up all the workers (we are 12) to use Thunderbird and synckolab so we all have the same addresses. It's been 2 or 3 years we've been using this combination and we are very glad for it (thanks to the developer!). Anyway, lately we begun having some issues while syncing, that ended up wit 200 copies of one contact, a couple of "unparseable" messages, etc. not a big deal since no data was lost, and I didn't have the time to check out what was going on.

So, I thought it was a good idea to, somehow, "start from scratch" the syncing from a cleaned version of the address book. What I did is follow the instructions to completely remove synckolab from one computer, then I cleaned the address book, and then I reinstalled synckolab, and set it up to work in a new server folder. What I wanted to do next is proceed for each user to erase their address book and set up synckolab to sync with the new server folder.

The weird think though is I didn't manage to get a really clean new db or address book. I guess some information (id?) is persistent even if I follow the manual uninstall. I ended up with a 950 contacts address book, but first sync got 990 entries (???). Then I saw that some of the entries in the list corresponded to old contacts I had before cleaning. It didn't have any real effect on the new address book (no new entries created), but there they are. And I tried adding a new contact and didn't sync...

OK, I could go on and describe all issues, but I think everything should work fine if I could get a real sync "from scratch". Can I get it with the address book I already have? meaning: is there an ID somewhere in the contacts that is messing this new start? formerly it used to be custom4 field...

Well, I hope you can understand something out of this mess I've just written, and I hope you can help me get what I'm looking for. Thank you very much in advance and don't hesitate to ask me whatever you need to know.

Miquel

PS: we all work on Windows machines (XP and 7), Thunderbird 9, and latest nightly of synckolab (but it's been going on for a while, through different nightly versions, as TB would fly through 5, 6, 7, 8, 9...).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mozdev.org/pipermail/synckolab/attachments/20120111/3fdd1579/attachment.html>


More information about the Synckolab mailing list