[Synckolab] Sync Calendar problems: some fail parsing, some are duplicated, deleted messages are not recognised as deleted

Jeff synckolab at aquabolt.com
Thu Apr 19 09:48:21 PDT 2007


Running on WinXP SP2
   Sync Kolab 0.4.32
   Thunderbird 1.5.0.10 (20070221)
   Lightening 0.3.1

Calendar save format is Kolab2 XML:

I have three small entries. 1 works fine, 1 fails to parse, 1 
continually is deleted and recreated. Here are the XML details:

This one works fine:
--------------------
<?xml version="1.0" encoding="UTF-8"?>
<event version=.0" >
  <product-id>Synckolab 0.4.31-ag, Calendar Sync</product-id>
  <uid>uuid1176997551890</uid>
  <start-date>2007-04-27T13:00:00Z</start-date>
  <end-date>2007-04-27T14:30:00Z</end-date>
  <summary>Allan - London</summary>
  <creation-date>2007-04-19T15:45:54Z</creation-date>
  <last-modification-date>2007-04-19T15:45:54Z</last-modification-date>
  <sensitivity>public</sensitivity>
  <organizer>
   <display-name>Synckolab</display-name>
   <smtp-address>synckolab at no.tld</smtp-address>
  </organizer>
  <revision>0</revision>
</event>



This one fails to parse: is it because it has an email in the attendee 
field?
--------------------------------------
<?xml version="1.0" encoding="UTF-8"?>
<event version=.0" >
  <product-id>Synckolab 0.4.31-ag, Calendar Sync</product-id>
  <uid>uuid1176997732406</uid>
  <start-date>2007-09-09</start-date>
  <end-date>2007-09-10</end-date>
  <summary>Lois arrives UK</summary>
  <creation-date>2007-04-19T16:10:02Z</creation-date>
  <last-modification-date>2007-04-19T16:10:02Z</last-modification-date>
  <body>after 18 days in transit</body>
  <sensitivity>public</sensitivity>
  <organizer>
   <display-name>null</display-name>
   <smtp-address>mailto:noone at nowhere.com</smtp-address>
  </organizer>
  <revision>0</revision>
</event>


This one continually deletes the existing record and recreates a new 
one, even though no changes have been made: Is it because it is an 
all-day event?
-------------------------------------------
<?xml version="1.0" encoding="UTF-8"?>
<event version=.0" >
  <product-id>Synckolab 0.4.31-ag, Calendar Sync</product-id>
  <uid>uuid1176998987093</uid>
  <start-date>2007-09-15</start-date>
  <end-date>2007-09-16</end-date>
  <summary>Sally's birthday in Paris</summary>
  <creation-date>2007-04-19T16:36:03Z</creation-date>
  <last-modification-date>2007-04-19T16:36:03Z</last-modification-date>
  <sensitivity>public</sensitivity>
  <organizer>
   <display-name>Synckolab</display-name>
   <smtp-address>synckolab at no.tld</smtp-address>
  </organizer>
  <revision>0</revision>
</event>

Observations:
* <start-date> and <end-date> on two problem entries have no time (all 
day events).

* fails-to-parse entry has null in <display-name> and an email in 
attendees (others have a synckolab email which doesnt appear in attendees?)

* sync kolab deletes and recreates messages - but then on subsequent 
sync, parses the messages it has deleted. I don't have automatic purge 
turned on - this setting would affect my entire IMAP connection.

Regards,

Jeff

PS: I tried to register with bugzilla to create a bug, no luck with the 
confirm email, an hour later.



More information about the Synckolab mailing list