[Pyxpcomext] ImportError with _Py_ZeroStruct in C extension

Todd Whiteman twhitema at yahoo.com.au
Mon Feb 8 17:36:19 PST 2010


Try building numpy with the actual Python in the PyhtonExt extension, 
i.e. use the following numpy build/install steps:

   export 
PYTHONHOME=/home/phyrephox/.mozilla/firefox/3tn4oxjv.reform/extensions/pythonext at mozdev.org/python
   export LD_LIBRARY_PATH=$PYTHONHOME/lib
   cd numpy-src
   chmod 700 $PYTHONHOME/bin/python2.6
   $PYTHONHOME/bin/python2.6 setup.py build
   $PYTHONHOME/bin/python2.6 setup.py install

Which will install numpy into the site-packages dir:
   $PYTHONHOME/lib/python2.6/site-packages

Does that one work any differently?

Cheers,
Todd

On 10-02-08 04:26 PM, William Cauchois wrote:
> Its interesting that you're having the same issue as me, with a
> completely different module.
>
> I just tried running my software on another system, and it worked perfectly.
>
> On Mon, Feb 8, 2010 at 2:45 AM, Elias Showk <elias.showk at iscpif.fr
> <mailto:elias.showk at iscpif.fr>> wrote:
>
>     Hi Todd and Bill,
>
>     I experience the same problems, since my previous thread
>     (http://www.mozdev.org/pipermail/pyxpcomext/2010-January/000136.html).
>
>     Following Todd's advice to import python packages with extensions
>     (numpy, bssdb3) into the xulrunner+python app  (by the way,
>     http://github.com/jbilcke/tinasoft.desktop), I used a UCS2 Python
>     2.6.4 (in fact an ActivePython-2.6.4.10-linux-x86_64).
>
>     Although it resolved the original issues (undefined _Py_ZeroStruct
>     from import bsddb3 and undefined Py_Unicode from import numpy), I
>     still have another import error from numpy :
>     "platform/Linux_x86_64-gcc3/pylib/numpy/core/multiarray.so:
>     undefined symbol: _Py_ZeroStruct"
>
>     Finally, I found no 32-bit builts into the entire source code
>     directory (nothing returned by $ find . | xargs file | grep ".*: .*
>     32-bit").
>
>     If anyone has an idea, or an advice, it could help a lot.
>     If I found something, I'll post it.



More information about the Pyxpcomext mailing list