[Pyxpcomext] ImportError with _Py_ZeroStruct in C extension

William Cauchois wcauchois at gmail.com
Mon Feb 8 16:26:24 PST 2010


Its interesting that you're having the same issue as me, with a completely
different module.

I just tried running my software on another system, and it worked perfectly.

On Mon, Feb 8, 2010 at 2:45 AM, Elias Showk <elias.showk at iscpif.fr> wrote:

>  Hi Todd and Bill,
>
> I experience the same problems, since my previous thread (
> http://www.mozdev.org/pipermail/pyxpcomext/2010-January/000136.html).
>
> Following Todd's advice to import python packages with extensions (numpy,
> bssdb3) into the xulrunner+python app  (by the way,
> http://github.com/jbilcke/tinasoft.desktop), I used a UCS2 Python 2.6.4
> (in fact an ActivePython-2.6.4.10-linux-x86_64).
>
> Although it resolved the original issues (undefined _Py_ZeroStruct from
> import bsddb3 and undefined Py_Unicode from import numpy), I still have
> another import error from numpy :
> "platform/Linux_x86_64-gcc3/pylib/numpy/core/multiarray.so: undefined
> symbol: _Py_ZeroStruct"
>
> Finally, I found no 32-bit builts into the entire source code directory
> (nothing returned by $ find . | xargs file | grep ".*: .* 32-bit").
>
> If anyone has an idea, or an advice, it could help a lot.
> If I found something, I'll post it.
>
> _______________________________________________
> Pyxpcomext mailing list
> Pyxpcomext at mozdev.org
> https://www.mozdev.org/mailman/listinfo/pyxpcomext
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mozdev.org/pipermail/pyxpcomext/attachments/20100208/ebe10427/attachment.html>


More information about the Pyxpcomext mailing list