[Project_owners] php Issues

Pete Collins pete at mozdevgroup.com
Wed Sep 29 10:35:16 PDT 2010


  I was working on it.

It should be fixed now ...

Please test out ...

All .php files should be renamed to .php.html

We are redirecting this by default.

Thanks

--pete



On 9/29/10 11:25 AM, Mycroft Project wrote:
> http://mycroft.mozdev.org/protected/nowrapper/editsource.php.html.html.php.html.php.html.php.html.php.html.php.html.php.html.php.html.php.html.php.html.php.html.php.html.php.html.php.html.php.html.php.html.php.html.php.html.php.html.php.html.php?pid=38948
>
> Redirect loop.
> Is not the sort of thing I want to see.
>
> Can we turn off this redirecting except for the special cases discussed?
>
> On 29 September 2010 17:51, David White<whitedavidp at yahoo.com>  wrote:
>> Thanks. That seems to help me make some progress. But I do have to
>> invoke the .php.html file directly. It seems that when the request for
>> the .php file get redirected, request parameters are somehow being lost.
>> Darn it!
>>
>> Mycroft Project wrote:
>>> PS you can put php in local.conf (irony...)
>>>
>>> eg
>>> if(strstr($_SERVER['SCRIPT_URL'], 'file.php.html'))
>>>   $local_conf_serve_as_is = ON;
>>>
>>> On 29 September 2010 17:09, Mycroft Project
>>> <mycroft.mozdev.org at gmail.com>  wrote:
>>>
>>>> http://mycroft.mozdev.org/source/browse/thunderplunger/www/
>>>> I don't see the .php.html
>>>>
>>>> Pete -
>>>>
>>>> http://mycroft.mozdev.org/source/browse/thunderplunger/www/validateEmail.php?rev=1.1
>>>> is redirecting to .php.html...
>>>>
>>>> .html is prob working but you need to turn off templating (use
>>>> $local_conf_serve_as_is):
>>>> http://www.mozdev.org/docs/localconf.html
>>>>
>>>> On 29 September 2010 17:02, David White<whitedavidp at yahoo.com>  wrote:
>>>>
>>>>> Thanks Pete. But my ThunderPlunger project's single php file is not
>>>>> working
>>>>> any more and I am stumped as to what I need to do. I test using my
>>>>> browser
>>>>> even though this routine is not supposed to present a UI as it is more
>>>>> like
>>>>> a service which my addon uses. The original routine at
>>>>> http://thunderplunger.mozdev.org/validateEmail.php was working fine.
>>>>> Then it
>>>>> stopped working and only displayed the contents of the file. I have
>>>>> copied
>>>>> the original file's contents to both a file ending in .html and one
>>>>> ending
>>>>> in .php.html and placed them via WinCvs along side the original file.
>>>>> But
>>>>> none of them work now. Indeed, the original no longer displays the
>>>>> file's
>>>>> contents. What am I doing wrong here? David
>>>>>
>>>>> Pete Collins wrote:
>>>>>
>>>>>>   Anyone who is experiencing any php issues please respond to this
>>>>>> thread.
>>>>>>
>>>>>> This way I can keep all open issues in one place.
>>>>>>
>>>>>> If you want php turned on for your project, don't reply to this thread.
>>>>>>
>>>>>> If we have enabled php for your and you are using .php files, rename
>>>>>> them
>>>>>> to .php.html and requests will be automatically redirected.
>>>>>>
>>>>>> Thanks
>>>>>>
>>>>>> --pete
>>>>>>
>>>>>>
>>>>> _______________________________________________
>>>>> Project_owners mailing list
>>>>> Project_owners at mozdev.org
>>>>> https://www.mozdev.org/mailman/listinfo/project_owners
>>>>>
>>>>>
>>>> --
>>>> Charles Caygill
>>>> Mycroft Project Owner
>>>> http://mycroft.mozdev.org
>>>>
>>>>
>>>
>>>
>>>
>> _______________________________________________
>> Project_owners mailing list
>> Project_owners at mozdev.org
>> https://www.mozdev.org/mailman/listinfo/project_owners
>>
>
>

-- 
Pete Collins - Founder, Mozdev Group Inc.
www.mozdevgroup.com
Mozilla Software Development Solutions
tel: 1-719-302-5811
fax: 1-719-302-5813



More information about the Project_owners mailing list