[Project_owners] Can't get update to work

Onno Ekker o.e.ekker at gmail.com
Fri Mar 7 02:38:36 PST 2008


Jesper wrote:


> I've changed the update.rdf, but it's still in the same location, and
> > now it does work...
> >
>
> Possible reason it just worked: mozdev.org uses mirrors to host the
> downloads folders, and they're all using different server setups. So if
> it just worked today, then it might not work tomorrow or the next
> minute. So you save yourself the trouble then you should use mozdevs
> default/recommended location for the update.rdf


I can't find the location for update.rdf in the recommendations on  docs |
mozdev.
Only page I find on updates and releases is
MozdevDownloadReleases<http://www.mozdev.org/drupal/wiki/MozdevDownloadReleases>,
which does not say anything on the location of update.rdf.

I've also searched in mozilla docs, and in Install Manifests -
MDC<http://developer.mozilla.org/en/docs/Install_Manifests#updateURL>it
does say that the content-type for
update.rdf must be either text/rdf or text/xml, but with
extensions.logging.enabled and using Find update for my project, I see it
getting the rdf info and ending with a status 8 all the time, so it seems
that application/vnd.mozilla.xul+xml also works. Haven't verified the source
in nsExtensionManager.js though.

Maybe mozdev and mozilla docs need some clarification on the matter...

Onno
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mozdev.org/pipermail/project_owners/attachments/20080307/b85b0796/attachment.html 


More information about the Project_owners mailing list