[Project_owners] Can't get update to work

Jesper Staun Hansen jesper at selvet.dk
Thu Mar 6 21:53:28 PST 2008


Onno Ekker wrote:
> Matthew Wilson wrote:
>   
>> Onno Ekker wrote:
>>   
>>     
>>> On Thu, Mar 6, 2008 at 6:11 PM, Matthew Wilson 
>>> <matthew at mjwilson.demon.co.uk <mailto:matthew at mjwilson.demon.co.uk>> wrote:
>>>
>>>     Onno Ekker wrote:
>>>      > Hi,
>>>      >
>>>      > I thought I understood how Thunderbird checks for updates, but it
>>>      > doesn't work for my extension, so I must do something wrong. I've
>>>     looked
>>>      > over it a couple of times, removed all the signing stuff,
>>>     rereleased and
>>>      > reinstalled original version, waited for mirrors to sync, etc, but it
>>>      > still doesn't work.
>>>      >
>>>      > This is what I have done:
>>>      > - forward-0.1-tb.xpi contains an install.rdf with updateurl
>>>      > http://downloads.mozdev.org/forward/update.rdf
>>>      > - update.rdf contains information for version 0.2, with updatelink
>>>      > http://downloads.mozdev.org/forward/forward-0.2-tb.xpi
>>>      > - forward-0.2-tb.xpi is the new version
>>>      >
>>>      > Do I misunderstand the way Thunderbird looks for updates, or
>>>     doesn one
>>>      > of the files contain wrong information?
>>>
>>>     If I try to load your RDF in Firefox, I get Page Info showing that the
>>>     content type is "application/vnd.mozilla.xul+xml". This won't work I
>>>     think; text/xml or text/rdf would be OK; I wouldn't be surprised if
>>>     application/rdf+xml worked too now.
>>>
>>>     Matthew
>>>
>>>
>>> I think the "application/vnd.mozilla.xul+xml" content-type gets added by 
>>> Firefox because of the file extension or the way files as served. If I 
>>> rename it to update.txt, Firefox displays its content type as plain/text.
>>>     
>>>       
>> No, the server is deducing the content type based on the file extension. 
>> Firefox isn't changing it.
>>
>> I tried to load the update.rdf a couple more times, and got different 
>> content types back each time. So I don't think you can rely on it 
>> working. Normally these update.rdfs are in the www directory of a mozdev 
>> project, not in downloads. I would recommend that you change yours to do 
>> this.
>>
>>   
>>     
> I've changed the update.rdf, but it's still in the same location, and 
> now it does work...
>   

Possible reason it just worked: mozdev.org uses mirrors to host the 
downloads folders, and they're all using different server setups. So if 
it just worked today, then it might not work tomorrow or the next 
minute. So you save yourself the trouble then you should use mozdevs 
default/recommended location for the update.rdf



More information about the Project_owners mailing list