[Project_owners] jslib problems with SuiteRunner

Philip Chee philip.chee at gmail.com
Mon Feb 25 06:21:09 PST 2008


On Mon, 25 Feb 2008 06:53:31 -0700, Pete Collins wrote:

> You should be using jsLib current ...

>   https://www.mozdevgroup.com/dropbox/jslib/signed/jslib_current_signed.xpi

> The global is a build w/ legacy install.js only for global install and 
> it's probably not supported in newer builds.

I guess this means that I'll have to contact the author of the Cookie
Panel extension.

Hmm.
cookiepanel-0.7.xpi  	2006-Feb-13
Doesn't sound good.


Phil

> Philip Chee wrote:
> 
>>The Cookie Panel extension on first invocation detects that jslib is not
>>installed and then attempts to download and install it. However it tries
>>to fetch jslib from:
>><http://www.mozdevgroup.com/dropbox/jslib/signed/jslib_current_global_signed.xpi>
>>However the installation fails with "unknown or malformed install.rdf".
>>I have manually downloaded this file and determined that the install.rdf
>>is indeed missing from this version of JSlib.
>>
>>This problem can be worked around by manually downloading the current
>>jslib.xpi, bumping the maxVersion to 2.0.* and then d'n'd on to SeaMonkey.
>>
>>Further more could the jslib developers increase the maxVersion for
>>SeaMonkey to 2.0.* (or at least 2.0a1)?
>>
>>Phil
>>
>>  
>>
> 


-- 
-==-
Philip Chee <philip at aleytys.pc.my>, <philip.chee at gmail.com>
http://flashblock.mozdev.org/ http://xsidebar.mozdev.org
Guard us from the she-wolf and the wolf, and guard us from the thief,
oh Night, and so be good for us to pass.



More information about the Project_owners mailing list