[Project_owners] File Removal / Permissions errors

Michael Johnston special.michael at gmail.com
Sat Apr 22 00:07:22 EDT 2006


i've seen the same error, i found that the only workaround i could get
to work was to move it to another file, and add to a list to try and
delete later. I still get a phantom copy lying around though.

(on a mac)

michael

On 4/21/06, Nickolay Ponomarev <asqueella at gmail.com> wrote:
> On 4/20/06, Brian King <brian at mozdev.org> wrote:
> > It throws this exception:
> > [Exception... "Component returned failure code: 0x80520015
> > (NS_ERROR_FILE_ACCESS_DENIED) [nsILocalFile.remove]"
> >
> > My first thought is that the application has a lock on it, but I can
> > delete it manually.
> >
> > So it looks like a file permission error. Any ideas?
> >
> Have you checked the permissions? Have you tried separating the
> fileObj.remove call into a separate function and calling it when
> you're sure the app doesn't have the lock? Have you tried tracking the
> issue down in a debug build?
>
> Nickolay
> _______________________________________________
> Project_owners mailing list
> Project_owners at mozdev.org
> http://mozdev.org/mailman/listinfo/project_owners
>


More information about the Project_owners mailing list