[Project_owners] Event.button in Firefox 1.5.0.2

Didier Ernotte didier at ernotte.com
Wed Apr 19 07:23:47 EDT 2006


Thanks for the link.
It seems to be related...

Didier

smaug <smaug at welho.com> wrote: Probably
https://bugzilla.mozilla.org/show_bug.cgi?id=297919

Alex Vincent wrote:
> 65535?  That doesn't sound right at all.
> 
> I'm going to cc smaug on this; he recently did a lot of work on DOM
> events, and he may have a clue.
> 
> On 4/17/06, Didier Ernotte  wrote:
>> Is it me or the value of the event.button keeps changing all the time
>> with every new release. In my extension I have some code that tests the
>> value of the left button with
>> if (event.button == 0) ...
>> and that was fine up to Mozilla 1.7 . With the preview of FF 1.5 and
>> the official release of 1.5 and 1.5.0.1 the value have change to
>> if (event.button == 65535) ...
>> and it was ok too with beta of FF 2.0
>> Now with the FF 1.5.0.2 I was to switch back to
>> if (event.button == 0) ...
>>
>> Does any body else have the same problem, or can I use an attribute of
>> some Interface like EVENT.LEFT_BUTTON to have always the correct value
>> ?
>>
>> Didier
>> _______________________________________________
>> Project_owners mailing list
>> Project_owners at mozdev.org
>> http://mozdev.org/mailman/listinfo/project_owners
>>
> 
> 
> --
> "The first step in confirming there is a bug in someone else's work is
> confirming there are no bugs in your own."
> -- Alexander J. Vincent, June 30, 2001

_______________________________________________
Project_owners mailing list
Project_owners at mozdev.org
http://mozdev.org/mailman/listinfo/project_owners

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mozdev.org/pipermail/project_owners/attachments/20060419/3998d797/attachment.htm


More information about the Project_owners mailing list