[Project_owners] [Offtopic] addons.mozilla.org

GuruJ GuruJ at mbox.com.au
Mon Nov 7 18:18:34 EST 2005


There isn't an official Mozilla 1.8, so any maxVersion will need to be 
1.7.* or less.

It makes no practical difference for Mozilla as far as the XPI goes 
though, since it doesn't actually use the RDF information -- it's just 
an amo thing.

-- GuruJ.

Gerald Vogt wrote:
> Sudhakar Chandra wrote:
> 
>> For Firefox, for some reason, they do not allow me to upload if I set
>> maxVersion to 1.5. I need to set it at 1.6 for them to allow me to 
>> upload.
> 
>  >...
> 
>> In the case of Mozilla, no maxVersion I chose seems to work. What
>> maxVersion should I be using for Mozilla 1.8b1?
> 
> 
> amo does not allow you to upload extensions for application versions 
> that have not yet been released. This is to prevent people from 
> submitting extensions for future releases. While the basic idea is 
> right, the logic how it is handled with minVersion and maxVersion is 
> flawed as you have noticed because amo allows extensions for FF 1.6a1 
> aka 1.6. As FF 1.5rc1 is out and reports as 1.5 it should work, but 
> unfortunately is does not, yet.
> 
> What you can do is submit the package with 1.4.1 as maxVersion which is 
> FF 1.5b2 I think. You can change the maxVersion of a package later on 
> the website. They offer 1.5 there, now, but I am not sure what you have 
> to specify in the install.rdf to get it. The HTML source code of the web 
> page shows a tag of "1.5*". Maybe that does work. If not, you probably 
> have to go with 1.4.1. (probably the reviewer will complain then that 
> you are not using the most current firefox version... ;-).
> 
> I don't know about the Mozilla versioning, though.
> 
> Gerald
> _______________________________________________
> Project_owners mailing list
> Project_owners at mozdev.org
> http://mozdev.org/mailman/listinfo/project_owners
> 


More information about the Project_owners mailing list