[Project_owners] Updating extension problem

Roman Mironenko roman_mir at hotmail.com
Mon Mar 28 22:02:00 EST 2005


Cross-posting?
That's interesting.

>
>http://forums.mozillazine.org/viewtopic.php?t=242273
>
>Cross-posting is lame.
>
>
>--- Matthew Wilson <matthew at mjwilson.demon.co.uk> wrote:
> > Firefox sometimes caches old versions of the file. Try loading the
> > RDF
> > file in your main browser window and reload until you get the
> > correct
> > version. Then try the update again. If that fails then clear your
> > cache,
> > restart and retry.
> >
> > Matthew
> >
> > Roman Mironenko wrote:
> > > Hmm, strange, I just fixed the reference it still gives out the
> > same error.
> > > I will have to spend more time on this.
> > > Thanks.
> > >
> > >> Roman Mironenko wrote:
> > >>
> > >>> Hi everyone,
> > >>> I wonder if anyone here has experienced the following:
> > >>>
> > >>> I have my extension on http://www.devlib.org/mozdev/russkey/
> > >>>
> > >>> and it is allright, if you don't have the earlier version the
> > >>> extension can be installed from there and works fine.  However
> > when I
> > >>> tested the update functionality on my setup (FireFox 1.0.2) on
> > win2k,
> > >>> and on winXP with this update RDF file:
> > >>> http://russkey.mozdev.org/russkeyupdate.rdf , I get the
> > following
> > >>> error: "Firefox encountered problems when updating your
> > software, and
> > >>> as a result not all components could be upgraded"  Details:
> > "Russ Key
> > >>> 0.2 (Not a valid install package.)"
> > >>>
> > >>>
> > >>> Now, when I test with this:
> > >>> http://russkey.mozdev.org/testrusskeyupdate.rdf RDF file (same
> > file
> > >>> but the extension version is 0.2.1) and with the russkey.xpi
> > file
> > >>> located on my computer
> > >>>
> >
>(<em:updateLink>file:///D:/development/cvs/russkey/downloads/russkey.xpi</em:updateLink>)
> >
> > >>>
> > >>>
> > >>> the extension updates just fine without any errors!
> > >>>
> > >>> Well, I am confused.
> > >>
> > >>
> > >> http://russkey.mozdev.org/russkeyupdate.rdf points to
> > >> http://downloads.mozdev.org/autocopy/russkey.xpi (in its
> > >> em:updateLink), which does not exist. Presumably you mean
> > >> downloads.mozdev.org/russkey/russkey.xpi.
> > >>
> > >> Matthew
> > >>
> > >> _______________________________________________
> > >> Project_owners mailing list
> > >> Project_owners at mozdev.org
> > >> http://mozdev.org/mailman/listinfo/project_owners
> > >
> > >
> > >
> > > _______________________________________________
> > > Project_owners mailing list
> > > Project_owners at mozdev.org
> > > http://mozdev.org/mailman/listinfo/project_owners
> > >
> >
> >
> > _______________________________________________
> > Project_owners mailing list
> > Project_owners at mozdev.org
> > http://mozdev.org/mailman/listinfo/project_owners
> >
>
>__________________________________________________
>Do You Yahoo!?
>Tired of spam?  Yahoo! Mail has the best spam protection around
>http://mail.yahoo.com
>_______________________________________________
>Project_owners mailing list
>Project_owners at mozdev.org
>http://mozdev.org/mailman/listinfo/project_owners




More information about the Project_owners mailing list