[Project_owners] Updating extension problem

Roman Mironenko roman_mir at hotmail.com
Mon Mar 28 16:26:40 EST 2005


Hi everyone,
I wonder if anyone here has experienced the following:

I have my extension on http://www.devlib.org/mozdev/russkey/

and it is allright, if you don't have the earlier version the extension can 
be installed from there and works fine.  However when I tested the update 
functionality on my setup (FireFox 1.0.2) on win2k, and on winXP with this 
update RDF file: http://russkey.mozdev.org/russkeyupdate.rdf , I get the 
following error: "Firefox encountered problems when updating your software, 
and as a result not all components could be upgraded"  Details: "Russ Key 
0.2 (Not a valid install package.)"


Now, when I test with this: http://russkey.mozdev.org/testrusskeyupdate.rdf 
RDF file (same file but the extension version is 0.2.1) and with the 
russkey.xpi file located on my computer 
(<em:updateLink>file:///D:/development/cvs/russkey/downloads/russkey.xpi</em:updateLink>)
the extension updates just fine without any errors!

Well, I am confused.




More information about the Project_owners mailing list