[Project_owners] Firefox app.extensions.version will increase soon

Robert J. Accettura robert at accettura.com
Mon Jul 26 07:55:39 EDT 2004


FYI

 From Ben Goodger's blog:
....

In the next week or so I will increase app.extensions.version to 0.10. 
This will end compatibility for all installed extensions with a 
maxVersion set to 0.9! If existing versions of you extensions are still 
compatible with the branch since 0.9, please contact update.mozilla.org 
and get the maxVersion setting in the database increased to 0.10! Code 
is landing in Firefox at the moment (see previous post) that mean that 
you do not need to create a new XPI if all you're changing is the 
maxVersion value in the install manifest! For Firefox 0.9/0.9.1/0.9.2 
users this means that when they upgrade to 1.0PR the browser will 
connect to update.mozilla.org and any custom RDF update files and 
attempt to version-patch before falling back on looking for new XPIs. 
1.0PR users will also be able to install incompatible extensions if a 
remote version patch is specified that designates compatibility with the 
new release.

*Extension and Theme Authors should start preparing for these changes NOW*

http://weblogs.mozillazine.org/ben/archives/006075.html

-- 
Robert J. Accettura
robert at accettura.com

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3182 bytes
Desc: S/MIME Cryptographic Signature
Url : http://mozdev.org/pipermail/project_owners/attachments/20040726/8472e291/smime.bin


More information about the Project_owners mailing list