[Project_owners] Wrong browser for installation

Ben Bucksch ben.bucksch.news at beonex.com
Sat Dec 20 14:24:54 EST 2003


You may want to take a look at browserOK() in my script 
<http://www.beonex.com/communicator/version/0.8/add-ons/install.js>. It 
also performs UA checks, can optionally check for a certain Gecko build 
date range or certain vendor releases, and gives appropriate error msgs.
Improvable is that the versions should be easier configurable, they are 
currently hardcoded in the script, which prevents checking for different 
versions (e.g. one package for 1.4, one for 1.6 etc.) using the same script.

The function is called implicitly by startInstall().

The script also offers a convience function genLaunch() for people who 
want to offer both a download link as well as an install button. A 
longer description can be found at 
<http://www.mozdev.org/notes/installation/>.



More information about the Project_owners mailing list