[LibX] DOIs not resolving in FF 3.5

Ed Jones ejones at nu.edu
Fri Sep 11 08:44:36 PDT 2009


We are having a problem with DOIs resolving correctly as well, though we use Serials Solutions 360 Link.  Rebuilding the edition has not solved the problem.

Three different responses are generated when clicking on DOIs associated with different issues of the journal Few-Body Systems in the EBSCOhost aggregation Academic Search Premier.  Clicking on doi:10.1007/s00601-009-0051-6 (the DOI of an article in a current issue-an article not available in the aggregation) resolves to the article page on the Springer Web site).  Clicking on doi:10.1007/s00601-008-0243-5 (the DOI of an article in an issue from last year-also an article not available in the aggregation) resolves to an EBSCOhost OpenURL Connection "No results were found page" (however, clicking on the 360 Link icon rather than the DOI takes you to the corresponding article page on the Springer Web site).  Finally, clicking on doi:10.1007/s00601-007-0193-3 (the DOI of an article in an issue from two years ago that IS now available in the aggregation) resolves to an EBSCO Publishing "Unknown Error Condition" page.

The DOIs are all valid and in each case the DOI on the originating Academic Search Premier article page is identical with the DOI on the target Springer article page.  So we have three distinct results when clicking on DOIs from different years of the same journal in the same aggregation.

I've also alerted Serials Solutions to the problem, since it may involve their OpenURL resolver rather than LibX.

Thanks for any insights you can offer.

Ed Jones
National University (San Diego, Calif.)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mozdev.org/pipermail/libx/attachments/20090911/56ca9e2e/attachment.html>


More information about the Libx mailing list