[LibX] LibX v Firefox 3.5

John Bickar jbickar at stanford.edu
Wed Jul 1 10:14:30 PDT 2009


Gotcha, now I understand. You had mentioned this in your reply to the 
message about "Broken cues in FF 3.5", but I didn't read it closely 
enough and thought my 1.5.7 was good-to-go.

Making the latest test revision live worked.

Thanks!

-John Bickar

Godmar Back wrote:
> 
> Yes, we made a mistake when we ran the script first (at about 1pm EDT). 
> That build does not have a correct update.rdf (see 
> http://libx.org/editions/B5/2B/B52BB6A8/update.rdf where it says: 
> <em:maxVersion>3.0.*</em:maxVersion> )
> 
> I corrected the bug around 4pm or so and repeated the built for all live 
> editions (though didn't send another email). For you, there's a test 
> revision at: http://libx.org/editions/B5/2B/B52BB6A8.8/update.rdf which 
> states the correct maxVersion. If you make that live, updates should work.
> 
>  - Godmar
> 
> 
> On Wed, Jul 1, 2009 at 12:55 PM, John Bickar <jbickar at stanford.edu 
> <mailto:jbickar at stanford.edu>> wrote:
> 
>     I'm getting a "no updates available" message even though I rebuilt
>     my edition and made it live yesterday. I have already tested it on
>     other computers with FF 3.5 and the rebuilt version (1.5.7) works;
>     however, I have found the following sequence of steps results in the
>     "no updates available" message:
> 
>     -Have LibX v. 1.5.6 (the pre-June-30th version) installed on FF 3.0.11
>     -Upgrade FF to 3.5
>     -LibX gets disabled
>     -Go to Tools->Add-ons in FF and click "Find Updates"
>     -LibX version shows as 1.5.6 and it says "No updates found"
> 
>     I seem to remember there being a delay before the "update available"
>     bit was set, but I thought manually clicking "Find Updates" overrode
>     that?
> 
>     Build ID is B52BB6A8.
> 
>     Thanks!
> 
>     -John Bickar
>     Stanford University
> 
>     Godmar Back wrote:
> 
> 
>         Correct - it should work if built after June 13.
> 
>         I have just started a script that will rebuild all 1498 live
>         editions and send an email to the edition maintainer explaining
>         what action is required if your live revision was not rebuilt
>         after June 13.
> 
>         In short, unless it was built after June 13, you need to test
>         and "make live" your test revision to ensure your users will
>         have an update available when they update to 3.5. Otherwise,
>         LibX will be disabled (though the browser will continue to check
>         for compatible updates should they later become available.)
> 
>          - Godmar
> 
>         On Tue, Jun 30, 2009 at 1:09 PM, Campbell, James (jmc)
>         <jmc at virginia.edu <mailto:jmc at virginia.edu>
>         <mailto:jmc at virginia.edu <mailto:jmc at virginia.edu>>> wrote:
> 
>            This was discussed here a couple of weeks ago. The LibX folks
>            reported having tested successfully with 3.5, added it to the
>         list
>            of FF versions compatible with LibX, and recommended a
>         rebuild.      It’s working fine for me. Unlike half my other
>         add-ons.
> 
>            
>                  - Jim Campbell
> 
>            
>                  Digital Access Librarian | Librarian for German
> 
>                  University of Virginia Library | Charlottesville, VA
>         22904-4112
> 
>            
>                  513 Alderman | campbell at virginia.edu
>         <mailto:campbell at virginia.edu>
>            <mailto:campbell at virginia.edu <mailto:campbell at virginia.edu>>
>         | 434-924-4985
> 
> 
>            
>            *From:* libx-bounces at mozdev.org
>         <mailto:libx-bounces at mozdev.org> <mailto:libx-bounces at mozdev.org
>         <mailto:libx-bounces at mozdev.org>>
>            [mailto:libx-bounces at mozdev.org
>         <mailto:libx-bounces at mozdev.org> <mailto:libx-bounces at mozdev.org
>         <mailto:libx-bounces at mozdev.org>>]
> 
>            *On Behalf Of *kristin buxton
>            *Sent:* Tuesday, June 30, 2009 1:00 PM
>            *To:* Dan Sich
>            *Cc:* libx at mozdev.org <mailto:libx at mozdev.org>
>         <mailto:libx at mozdev.org <mailto:libx at mozdev.org>>
> 
>            *Subject:* Re: [LibX] LibX v Firefox 3.5
> 
>            
>            I just rebuilt and it worked fine for me.
> 
>            On Tue, Jun 30, 2009 at 9:58 AM, Dan Sich <dansich at gmail.com
>         <mailto:dansich at gmail.com>
>            <mailto:dansich at gmail.com <mailto:dansich at gmail.com>>> wrote:
> 
>            Greetings,
> 
>            I'm seeing some posts in twitter suggesting that LibX won't work
>            with Firefox v 3.5.  Will a re-build surmount this problem, or is
>            there more work to be done under the hood at the developer end?
> 
>            Thanks,
>            Dan Sich
> 
>            University of Western Ontario
> 
>            _______________________________________________
>            Libx mailing list
>            Libx at mozdev.org <mailto:Libx at mozdev.org>
>         <mailto:Libx at mozdev.org <mailto:Libx at mozdev.org>>
> 
>            https://www.mozdev.org/mailman/listinfo/libx
> 
>            
> 
>            _______________________________________________
>            Libx mailing list
>            Libx at mozdev.org <mailto:Libx at mozdev.org>
>         <mailto:Libx at mozdev.org <mailto:Libx at mozdev.org>>
> 
>            https://www.mozdev.org/mailman/listinfo/libx
> 
> 
> 
>         ------------------------------------------------------------------------
> 
>         _______________________________________________
>         Libx mailing list
>         Libx at mozdev.org <mailto:Libx at mozdev.org>
>         https://www.mozdev.org/mailman/listinfo/libx
> 
>     _______________________________________________
>     Libx mailing list
>     Libx at mozdev.org <mailto:Libx at mozdev.org>
>     https://www.mozdev.org/mailman/listinfo/libx
> 
> 


More information about the Libx mailing list