[LibX] Bookmarklet passing %20 instead of space

Godmar Back godmar at gmail.com
Tue Oct 7 13:03:02 PDT 2008


ps for the list: turned out to be a bug in Scholar's Portal, not in LibX.
Their server was double-encoding correctly encoded data while
redirecting to another location.

 - Godmar

On Tue, Oct 7, 2008 at 9:01 AM, LibX Project <libx.org at gmail.com> wrote:
> If the %20 shows up in the search field, we would be double-encoding it.
> There were bugs with double-encoding in previous versions of the LibX
> code, which however - I hope - we've since fixed.
>
> Could you try a recent build and if that doesn't fix it, report to us
> with edition id and catalog number, possibly using the "Help Me With"
> button in the edition builder?
>
>  - Godmar
>
> On Tue, Oct 7, 2008 at 8:37 AM, Tim Knight/osgoode
> <TKnight at osgoode.yorku.ca> wrote:
>>
>> Hello all,
>> One of our bookmarklets searches a consortial database called Scholars
>> Portal.  When keywords are passed to the search engine spaces are replaced
>> with %20 which causes the search to fail.  I'm sure this was working in a
>> previous edition of LibX but I haven't had a chance to try and trace when
>> the change occurred.  Has anyone else encountered this?  And, more
>> importantly, know how to stop this from happening?
>> Thanks.
>> Tim
>>
>> ----------------->
>> F. Tim Knight, Head of Technical Services
>> Osgoode Hall Law School Library
>> York University
>> tknight at osgoode.yorku.ca
>> (416) 650-8403    Fax:  (416) 736-5298
>> http://library.osgoode.yorku.ca
>> ---------------------------------->
>> _______________________________________________
>> Libx mailing list
>> Libx at mozdev.org
>> https://www.mozdev.org/mailman/listinfo/libx
>>
>>
>


More information about the Libx mailing list