[Jslib] jslib:about doesn't work

Pete Collins pete at mozdevgroup.com
Sun Aug 5 07:23:38 PDT 2012


On 8/4/12 3:27 PM, David VANTYGHEM wrote:
> Hello,
>
> jslib:about as an URL works well with Mozilla firefox Portable version
> 3.6.28 but doesn't work with recent versions (13, 14..).

That is correct. That code has been since broken in the newer builds.

>
> I think there's a relation with this another problem : I can install
> and activate Jslib in all versions of Mozilla Firefox but my software
> https://sourceforge.net/projects/compilibre/files/COMPILIBRE-installer.xpi
> works only with Mozilla firefox Portable version 3.6.28, it doesn't
> work with recent versions, I've got the following error :

Yes this too is broken. The "jslib" top level DOM object is broken in
newer builds of Mozilla.

To fix, you will need to include jslib in your XUL files.

eg:
 
  <script type="application/javascript"
src="chrome://jslib/content/jslib.js" />

--pete

-- 
Pete Collins - Founder, Mozdev Group Inc.
www.mozdevgroup.com
Mozilla Software Development Solutions
tel: 1-719-302-5811
fax: 1-719-302-5813 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mozdev.org/pipermail/jslib/attachments/20120805/6a4efe2b/attachment.html>


More information about the Jslib mailing list