[Jslib] jsLib 0.1.352 xpi - Compatibility with Other Apps

Jane Ocean addonsmirror at gmail.com
Sat Jun 16 12:38:05 PDT 2007


Jane Ocean sent a subspace message on 6/15/2007 10:35 AM:
> Pete Collins sent a subspace message on 6/14/2007 5:02 AM:


>>> Also, do you have any plans for making jsLib available on Flock?

>> Ok, I added support for Flock to install.rdf:

>>    <!-- Flock -->
>>    <em:targetApplication>
>>      <Description>
>>        <em:id>{a463f10c-3994-11da-9945-000d60ca027b}</em:id>
>>        <em:minVersion>0.1</em:minVersion>
>>        <em:maxVersion>2.0.0.*</em:maxVersion>
>>      </Description>
>>    </em:targetApplication>

>> I pretty much guessed the version ...

>> So maybe someone can let me know if it doesn't install.

>> --pete

> Does this need to be added to both sections of the install.rdf file or
> just the top section?

> TOP SECTION
> <!-- Target Application this extension can install into,
>         with minimum and maximum supported versions. -->

> BOTTOM SECTION
> <!-- Packages, Skins and Locales that this extension registers -->

> I just added it to the TOP section only, and it works.  Other
> Mozilla-based applications also work.

> jsLib 0.1.352 changes to install.rdf:
> - increased Firefox maxVersion to 3.0.*
> - increased Thunderbird maxVersion to 3.0.*
> - added Flock support 0.1 - 2.0.*
> - added Sunbird support 0.3.1 - 0.6.*
> - added Nvu support 1.0 - 1.1
> - added Netscape support 9.0a1 - 9.1

> jsLib-dependent add-ons tested:
> - TagZilla 0.066 (modified same as jsLib)
> - Launchy 4.2.0 (modified same as jsLib)

> TEST RESULTS

> Firefox 1.5.0.12 - PASSED
> Firefox 2.0.0.4 - PASSED
> Firefox 3.0a5 Gran Paradiso - PASSED
> Firefox 3.0a6 Minefield - PASSED

> Thunderbird 1.5.0.12 - PASSED
> Thunderbird 2.0.0.4 - PASSED
> Thunderbird 3.0a1 - PASSED

> Sunbird 0.3.1 - PASSED
> Sunbird 0.4a1 - PASSED
> Sunbird 0.5rc1 - PASSED
> Sunbird 0.6a1 - PASSED

> Flock 0.7.14 - PASSED
> Flock 0.8.0.99 Sulfur - PASSED

> Netscape 9.0b1 - PASSED

> Nvu 1.0 - PASSED

> I hope this is helpful in your continuing development of jsLib.

> Jane


jsLib 0.1.352 also works with these other Mozilla-based applications:

eMusic DLM 4.0a1 - 4.0.*
Songbird 0.2 - 0.3.*








More information about the Jslib mailing list